Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

XX Please check your config setting

 

Indexhibit version: Legacy
Thread is not resolved.

popkiltr
UNITED STATES
10 year(s) ago
Permalink Post

The same questions again, but I have read all the posts and I am stuck as well.

When I finish my site, I will absolutely put a link to indexhibit.org. I actually found out about this from a www.wonderfulunion.com. He is a friend and a very talented designer.

My webhost is using: Apache Version 2.2.8 (Unix)
Operating System: Linux

I contacted my webhost to find the Database Server: localhost
(support responded with local host, but i tried it both ways)
I created MySQL Database Name: phaek_BrianShevlin
I created a database username: phaek_phaek
And the password is {Removed users password}

I can send screen captures of my control panel etc if that helps.

I don't understand why I keep getting the error message.
Thanks - Brian

popkiltr
UNITED STATES
10 year(s) ago
Permalink Post

To confirm, I spoke with my webhost and these are correct...

Vaska A
UNITED STATES
10 year(s) ago
Permalink Post

Sorry, but something isn't right there. Should work...if everything is as you say it is.

popkiltr
UNITED STATES
10 year(s) ago
Permalink Post

I'm confused.
I'm no expert in the field, but I believe I understand enough.
I tried to change the htaccess and put a . in the front, but it said the file already exists... maybe from my previous website hosted there, but... I set my preferences to see invisible files, and I don't see one listed. Should I change this anyways and rewrite the current file?
That should have anything to do with this though, correct?

Vaska A
UNITED STATES
10 year(s) ago
Permalink Post

This part has nothing to do with the htaccess file...unless you have edited it incorrectly (which I hope you aren't doing).

I'm going to guess that 'localhost' is not correct. Double and triple check the information you get from the host. I've been through this hundreds of times now...pretty sure something is not right there.

popkiltr
UNITED STATES
10 year(s) ago
Permalink Post

I figured it out!
Thanks for the fast replies... solving it had to do with this I found below, which might help others new to this stuff...

CREATE DATABASE creates a database with the given name. To use this statement, you need the CREATE privilege for the database. CREATE SCHEMA is a synonym for CREATE DATABASE as of MySQL 5.0.2.

An error occurs if the database exists and you did not specify IF NOT EXISTS.

create_specification options specify database characteristics. Database characteristics are stored in the db.opt file in the database directory. The CHARACTER SET clause specifies the default database character set. The COLLATE clause specifies the default database collation. Section 9.1, “Character Set Support”, discusses character set and collation names.

Thanks again, awesome support...
+Brian

Vaska A
UNITED STATES
10 year(s) ago
Permalink Post

Aha...db privileges...server setup.

Great!

kheesiong
UK
9 year(s) ago
Permalink Post

Hi Vaska,

I think i have the same problem as Brian, do I set my privileges on my MySQL? If so how do I do it? I'm on :

http://mysql11.streamline.net/phpmyadmin/

and I cannot find a way to do this...

Thanks

Vaska A
UNITED STATES
9 year(s) ago
Permalink Post

Not via phpmyadmin...your host control panel should have them and that I would know nothing about.

;)

kheesiong
UK
9 year(s) ago
Permalink Post

thank you Vaska, I will try to sort this out...

ellekorhaliller
UNITED KINGDOM
9 year(s) ago
Permalink Post

Hey again Vaska,
I am now on the config database screen. I have just emailed my host the following:

I am trying to run an application on my domain called Inexhibit. During the install process it is asking me for my:
Database server:
Database name:
Database username:
Database password:
What are these please? Are they simply my cPanel login info and do I make the database name up? I don't have any experience with databases!

Thank you

To which they replied:

Thank you for your support enquiry.

Inexhibit is a third party software and therefore not something we support or know alot about, it would seem that a database would be required to use this software but I would suggest that you have a look on their website for further details and a possible setup guide. The website, indexhibit.org, has a forum, help and tutorials on the software which you may find useful.

Thanks again for contact Fasthosts.

Are we meant to set up a new database ourselves in our cPanels for inexhibit?

Vaska A
UNITED STATES
9 year(s) ago
Permalink Post

Wow...so we are supposed to know how all of their stuff is setup? Wrong...we don't. They must have instruction somewhere on their site for you to get started setting up the database (this is not our part of things).

You know...they get paid to host your site. We don't get paid for this...

cruz
PORTUGAL
9 year(s) ago
Permalink Post

I find this explanation by blame from this thread to be very helpful, and thought it would be nice to post it here:

Exhibition Name: The name of your website. You can change this later (in Settings not Preferences) if you need, so it's not that important.

Database Server: Depends on your server, but mine was just 'localhost' but sometimes it's "mysql.your-domain-name-here.org" or something along those lines. If you don't know — ask your host.

Database Name: This is important that you set this up before trying to install Indexhibit. It all depends on your host, but mine uses CPanel to get to a screen called "MySQL Databases." You pick a name (like, say, ndx) and make a new database. Sometimes it'll change the name to something like usrnme1_ndx where usrnme1 is what your specific login is. That's sometimes the case when you are doing shared hosting, but not always. If this isn't somewhere you can find when you log into some sort of control panel (hint: you can't do this from your FTP) — ask your host. You're paying them, they can show you were to make a database. If you don't have databases, you can't install Indexhibit, and you should find a more modern host.

Database Username/Password: This is also important that you set this up before you install. The same screen (again, from my host; yours may be different) you need to add a new user to the database you just made. Mine likes to add the usrname1_ we talked about, but not always. For me it was a two-step process.

1) Create the user and set a password for it.
2) Add that newly-created user to the usrnme1_ndx database.

Those are the values you need. Once you get inside, things get a little less cryptic.

But seriously, this forum is a wealth of information. Just go back and read pages of these; most of the issues you would ever have have probably been touched on by someone. It's not about geek pride; it's about using the DIY method. You could just buy a hosted solution or use like a Fantastico script to get Wordpress up in a jiff. But what makes Indexhibit cool is that you have to get a little messy with it to make it work and feel just how you like. It's fun, trying at times, but fun.

YTTE
UNITED STATES
9 year(s) ago
Permalink Post


Hello

I will definitely put a link to indexhibit on my site once I get it up.

I confirmed with my hosting company that my database info is correct for their server:

Exhibition Name:
http://www.tracymolis.com

Database Server:
t_molis.db.4225418.hostedresource.com

Database Name:
t_molis

Database Username:
t_molis

Database Password:
********* [can I post password privately?]

I keep getting the error message nonetheless. Any tips on how to take it from here?

cheers--Tracy

Vaska A
UNITED STATES
9 year(s) ago
Permalink Post

It's hard for us to say...but it could be helpful to tell us what the error messages are.

YTTE
UNITED STATES
9 year(s) ago
Permalink Post


Thanks for your prompt response, I appreciate it.

The message is:

XX Please check your config settings again.

YTTE
UNITED STATES
9 year(s) ago
Permalink Post

Would it help for me to give you the password?

tigermurphy
UNITED STATES
9 year(s) ago
Permalink Post

Hi. I just wanted to share how I solved the problem I was having with installing Indexhibit. I'm new to web stuff and thought this might help someone else. I got the error message when trying to input the database information. I thought the problem was the database server name (which turns out to be what it defaulted to, localhost). But the problem was actually my database username. As someone mentioned in the post above, what can happen when you're dealing with shared hosting as I am, the web host sees the username as "mylogin_username". I thought the database username was simply the one word "username" (which I had specified in the database settings) but it was actually "mylogin_username" I hope that makes sense and can help someone else.

tyler
UNITED STATES
8 year(s) ago
Permalink Post

Hello!

So I have read through all of the threads about this that I have found, and everything seems to be answered very well.. but this step is still eluding me.

I recently sent an e-mail to be web host (JustHost), and they confirmed that the Database server, Database name, and Database username were all correct, but I still get the "XX Please check your config settings again." error message. This is what they told me exactly:

"
Please try to use the following settings
Database server: localhost
Database name: tylerca1_trcart
Database username: tylerca1_tylerca
Database password: your password for this database
"

The Exhibition name is the only other variable, but if it does not matter what the Exhibition name is, then I have no idea what to do. Can anyone help?

Thanks in advance!

lcd
UNITED STATES
8 year(s) ago
Permalink Post

Hi,

I've read through the issues; and I seem to be having the same problem as YTTE; how was it resolved?

Thanks,

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

Please explain what the problem is...

lcd
UNITED STATES
8 year(s) ago
Permalink Post

when I go to set up the database; I type in the following:

Exhibition Name:
http://www.lcddesignsystems.com

Database server:
indexhibit_lcd.db.4468182.hostedresource.com

Database Name
indexhibit_lcd

database username:
indexhibit_lcd

Database pw:
[deleted]

and it says

xx please check your config settings again

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

Ask your host to confirm the database connection info. I bet that either your database name or username are incorrect.

Which host is that?

lcd
UNITED STATES
8 year(s) ago
Permalink Post

strike that. i needed to capitalize one one. its working now of course now i can't figure out the login, but that's another page

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

The temp login is:

Login: index1
Pwd: exhibit

Awesome that you got it working.

;)

tyler
UNITED STATES
8 year(s) ago
Permalink Post

Hi, so I still do not know what the problem is with my database information. Is it something you can tell by what I have posted?

Thanks.

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

Nope, can't really tell. When people are stuck at this place we always give the same advice (we've posted it around here many times including in this thread) and they always eventually get it right.

tyler
UNITED STATES
8 year(s) ago
Permalink Post

Ah, ok I got it. It had to do with privileges. Thanks Vaska. I feel silly.

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

Great!

sam000gm
UK
8 year(s) ago
Permalink Post

hi, I am installing on a different host than usual and having issues...
I have checked with the host that the details I'm using are correct.

I suspect that it has something to do with database privileges but I am not sure. I think it relates to this previous post from Brian above, but could you explain what I have to do to resolve it?: thanks in advance.

I figured it out!
Thanks for the fast replies... solving it had to do with this I found below, which might help others new to this stuff...

CREATE DATABASE creates a database with the given name. To use this statement, you need the CREATE privilege for the database. CREATE SCHEMA is a synonym for CREATE DATABASE as of MySQL 5.0.2.

An error occurs if the database exists and you did not specify IF NOT EXISTS.

create_specification options specify database characteristics. Database characteristics are stored in the db.opt file in the database directory. The CHARACTER SET clause specifies the default database character set. The COLLATE clause specifies the default database collation. Section 9.1, “Character Set Support”, discusses character set and collation names.

Thanks again, awesome support...
+Brian

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

These are settings your webhost provides in your hosting control panel.

sam000gm
UK
8 year(s) ago
Permalink Post

Thanks for quick response, still not sure how to change things. (I think by default ALL PRIVILEGES are set for the database.)

annoying i know, and host specific, but which of these are most likely the value for the Database Server field at install?

MySQL 16
mysql16.streamline.net
79.99.43.21

(( has anyone had problems with Streamline.net? ))

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

Why can't you ask your host for this info? We don't know it...how many times do I need to tell people this?

Just ask your host for the connection info.

Emily_Vezer
CANADA
8 year(s) ago
Permalink Post

Hello, I'm stumped at the Database server name.
Looks like I have three options with my webhost (I'm with media temple).
There is an internal hostname, an external host name and en environment name.
I've tried all three options here and nothing seems to work.
I have made a new database name with media temple which gives me a username and password.
Any ideas why it's not working?
Thank you for helping.
E

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

Stop double posting...you posted the exact same thing in another thread.

thibaud
FRANCE
8 year(s) ago
Permalink Post

Hi,

I have the same problem. I'm a novice (and french) and i don't really understand where i can find the Database server, Database name, Database username and Database password.
I tried different things but it still doesn't work. How to know which one is wrong... I just need to find these informations on my 1and1 account or in cyberduck?
I just don't know...

Sorry for this basic question but I'm trying to figure out this setting problem for 2 hours.

Thanks.

lemathieu A
FRANCE
8 year(s) ago
Permalink Post

La meilleure solution est de contacter dirctement ton hébergeur et de lui demander.

thibaud
FRANCE
8 year(s) ago
Permalink Post

Merci de la réponse rapide et en français, je les contacte sur le champ.

harrism07
UK
8 year(s) ago
Permalink Post

I seem to be having similar problems with config issues.

I had already installed indexhibit, and had a functioning site for some time now however, after some css customizing went a bit wrong a completely deleted everthing on my FTP and deleted my database.

I started a fresh, recreated a new database and verified details with my host. But for some reason I still cant get past the 2nd part of the install. It just says XX Please check your config settings.

any help would be most appreciated

harrism07
UK
8 year(s) ago
Permalink Post

No worries, I got it sorted.

My hosting service did it for me. they said

'To connect to your database you needed a user assigned to the database with permissions for the database.

I saw that you had created the user:*********** but it was not assigned to the database.

I have gone ahead and done that.'

lesley
UNITED KINGDOM
8 year(s) ago
Permalink Post

managed to do this once before for myself through 'easyspace' so proposed to a friend that I'd do the same for her. Good idea? Nope.
Problem: get to installation and XX please check your config setting.

123-reg have confirmed that all db info is correct and I've double checked my config settings on the 'files', 'gimps' and 'config'. Also read the thread about db priveleges but not sure how to do this.
123-reg say they are a shared server and that I may not be able to change my db priveleges!

exhib name: www.ladyleemilne.co.uk
db host:cust-mysql-123-01
db name:ladylemilnecouk_417912.db1
db user: uladyle_417912_1
db pass:

Any guidance would be greatly appreciated!

Lesley

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

Looks to me that the site isn't even through propogation yet...I can't see anything on this domain.

kieran_gee_finch
UK
8 year(s) ago
Permalink Post

Hi there, I have set up an hosting account with streamline.net

I have installed the indexhibit file, following the guide for dummies indexhibit have so kindly provided.

I have got to the second part of activation, after getting three green X's on the first part,
when putting in my mySQL data base information provided I get the XX config setting prompt... I have no idea what I am doing wrong...?

This is what I am entering...

SERVER: MYSQL 17
HOSTNAME: 213.171.220.32
DB NAME: wunderland1

I am not including my pw for obvious reasons.

Any help would be great,

:)

jaz
CANADA
8 year(s) ago
Permalink Post

Hey,
this problem above

during the INSTALL where you input the info:

Exhibition Name
Database Server
Database Name
Database User
Database Password

and get: XX Please check your config settings...

——————

I realized when creating my database, that I DID NOT *ADD* the USER I had created TO the DATABASE I had created.

——————

I then ADDED the USER I had created (in the MySQL databases section in the cPanel of my server/website)

TO the DATABASE I had created.

And it worked! I moved onto the next step of the installation.

Hope this helps,
all the best,
Jaz

barbarella
UK
8 year(s) ago
Permalink Post

Lesley: you changed settings for the 'gimps' file? am i in the wrong forum?

barbarella
UK
8 year(s) ago
Permalink Post

I had trouble with config settings using Fasthosts too.

Then I realised that what they describe as the server name isn't what indexhibit is after. When Indexhibit asks for the Server Name you need to give it the Server IP Address. Discovered that by reading between the lines on another forum here. Thanks

sjorgens
UNITED STATES
8 year(s) ago
Permalink Post

I have a solution for anyone using hostgator. I had the same problems as everyone else.

I just clicked on mysqlwizard under databases and went through it step by step. In the wizard it will allow you to set the privileges for the database which I think is the main problem people are running into.

hope this helps!

Now I just have to figure out eveything else to do with this bloody thing ;)

panopticon
UK
8 year(s) ago
Permalink Post

OK -IF YOU"VE GOT TO HERE AND ARE STILL HAVING TROUBLES this might help.

As a dummy user of anything web based i've found it hard to get passed the database login settings. First thing to do As Vaska says: CONTACT YOUR WEB HOST and get them to tell you all that you need as Vaska said - your paying them!.

First you need a database! - ( using Streamline.net i had to upgrade from a Home User to a Power User account, paying the difference, they were very helpful.)

Second you need all the Info off them: They send you it via email and via support ticket help- this is what they sent me:

DB Hostname: 213.171.220.32
DB Username/Name: roejobcons1
DB Password: ******* (undisclosed)

This i eventually translated thus for indexhibit:

exhibition name: roejob (doesn't matter what this is)
database server: 213.171.220.32
database name: roejobcons1
database username: roejobcons1
database password: ******* (undisclosed)

It took a few attempts but now i'm in.
If you've got any further problems then it'll probably be how you uploaded Indexhibit files to your host. Probably delete and refresh- making sure you don't delete your database.

Hope this helps.

nailer
IRELAND
8 year(s) ago
Permalink Post

Hi,

I cant get past the insatllation.

I've gotten the information from the server provider:

Database server: mysql2.hosting.digiweb.ie (also tried     78.137.166.6)
Database name: nailer_moc
Database username: nailer_nailer
Database password: *******

I still just get the message:
XX Please check your config settings again

I've gone through the forums but I cant find anything that helps.

What can I do? Please help. I've been at this for days.

Vaska A
UNITED STATES
8 year(s) ago
Permalink Post

If the information is correct it will work...I'm guessing it's not.

Showing 1 - 50 of 61 posts in Forum » Installation » XX Please check your config setting
 

This thread has been closed, thank you.