Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

Update to version 71

 

Indexhibit version: Legacy
Thread is not resolved.

Vaska A
UNITED STATES
6 year(s) ago
Permalink Post

Today we've pushed out a minor set of updates to older versions of Indexhibit - you can find the files on the downloads. You only need to download the update set of files.

Indexhibit v71 Update

These files will update your Indexhibit site to version 71. This update contains fixes for PHP 5.3 related issues and general security updates.

Note that if you have clean url's enabled or have changed the default thumbnail/file sizes you will need to update the /ndxz-studio/default.php file after you have replaced your files. Also, if you have customized your system files (not your site files) you will lose any of these changes with this update.

- backup all your Indexhibit site files first
- unzip the files
- replace your root 'index.php' file
- replace all files in the 'update ndxz-studio' folder to your 'ndxz-studio'

This update is highly recommended.

adega
SPAIN
6 year(s) ago
Permalink Post

Hi Vaska,

What do you mean with "System files"? Changes in the database? Is this overwriting the Multi-language Plugin?

Thanks for the update!!

Vaska A
UNITED STATES
6 year(s) ago
Permalink Post

No, because that file is in your /ndxz-studio/site/plugin folder right? We aren't touching that folder...

No changes to the database either - this is a light update that people will need especially if they don't want to upgrade to a new Indexhibit.

We will continue supporting that version into the future, as well (meaning, there will be more updates as needed).

katarina
UNITED STATES
6 year(s) ago
Permalink Post

Hi Vaska, I just did an update. I figured it's better to do it before I start building the content of the site. But, there was a problem. I followed the instructions, replaced all the files and ended up with this message on my home page:

Fatal error: Call to undefined function getNow() in /home/content/15/8961515/html/ndxz-studio/lib/statistics.php on line 245

I have no idea what it means. I was thinking replacing the new statistics.php file with the old one - is that a good idea?

Thx!

katarina
UNITED STATES
6 year(s) ago
Permalink Post

Oh no, another problem. When I'm on my indexhibit home page i'm getting:

Fatal error: Call to undefined function directions() in /home/content/15/8961515/html/ndxz-studio/lib/router.php on line 34

Is there something wrong with the update? I haven't changed any .php files so far. I'm an absolute beginner, needless to say.
So, what should I do know?! Change it back as it was? Please help. Thank you!

katarina
UNITED STATES
6 year(s) ago
Permalink Post

Forgive me for messing up this thread. the helper folder was out of the hdxz-studio folder. Stupid/beginner me. Everything looks to be working now.

jayem
AUSTRALIA
6 year(s) ago
Permalink Post

i ran the update and received 3 errors on the exhibits page:
Strict Standards: Creating default object from empty value in ndxz-studio/module/exhibits/index.php on line 734

Warning: Cannot modify header information - headers already sent by (output started at ndxz-studio/module/exhibits/index.php:734) in ndxz-studio/common.php on line 188

Warning: Cannot modify header information - headers already sent by (output started at ndxz-studio/module/exhibits/index.php:734) in ndxz-studio/lib/template.php on line 66

as well as no longer being able to access the main index.php page. should i just revert to the 7.0 and wait for 7.2?

danuk
SWITZERLAND
6 year(s) ago
Permalink Post

great news, great!

about the update v71:
my webhost has php version 5.2.6-1 installed and will not update to php 5.3. so can i install the update anyway?

pernin
SWEDEN
6 year(s) ago
Permalink Post

yes, you can (and you should for the security update), just be sure you have your files backed up, that's common sense ;)

lemathieu A
FRANCE
6 year(s) ago
Permalink Post

If you have any problem, leave your site address (forum rules).
Thanks.

Daithi
IRELAND
6 year(s) ago
Permalink Post

Hi there

I tried to install v71 from scratch today, on a freshly created database. I ran into trouble, so I tried it on a different host and database. Same issues. I gave up, and tried v70 (it's just for a test site for me to play with) and that worked.

The issue seems to stem from the inclusion of a config.php file in the ndxz-studio/config folder; although removing it doesn't fix the issue.

On visiting the mysite.com/ndxz-studio/install.php page, there is a warning that ndxz-studio/config/config.php should not be present. On removing that file, the form is displayed as you would expect, but on submitting, an error message relating to the config settings is returned.

I'm not sure if others are having this issue. As I said I successfully installed v70 once I had given up on the other approach. I thought that I might have downloaded the wrong file (the update one perhaps) but that was not the case.

nichtchris
GERMANY
6 year(s) ago
Permalink Post

just did the update, everything works fine!

i also tried a fresh installation on my local mamp 2.0.5 running php 5.3.6 (osx 10.6.8) - also no problem!

thank you for the update : )

pernin
SWEDEN
6 year(s) ago
Permalink Post

@daithi: you're correct, a config.php found its way in that shouldn't be there, legacy from testing... and also some other details

Although I just tested a clean installation and removing the config.php file *does* solve the problem. You may have had a problem with a partial installation

Let's say that those trying to do a clean install just have to delete the file ndxz-strudio/config/config.php, until Vaska announces here that it's been fixed

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

Just did the update! everything went perfectly.

Thanks!

www.brucemyren.com

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

I thought everything went fine but now I cannot login to my admin pages.

www.brucemyren.com

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

When I try to login to http://www.brucemyren.com/ndxz-studio/?a=exhibits

I get this:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, hostmaster@dogbark.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

Please disregard all of my previous posts up to the everything worked, because it is fixed. Thanks!

Bruce

anpez
ITALY
6 year(s) ago
Permalink Post

Aggiornamento riuscito perfettamente...
Grazie!
www.antoniopezzanofotografo.com

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

Hi All,

I found a small issue, in my titles I am getting a backslash after zeros. This only happens when I update the image in the exhibit, or add a new image.

N 40° 00' 00" W 124° 00' 00" becomes N 40° 00' 00" W 124° 00' 00"

Thanks
Bruce

www.brucemyren.com

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

Fixed now, you have to use curly quotes not the keyboard " or '

Bruce

crosbyharbison
UNITED STATES
6 year(s) ago
Permalink Post

I am also having a similar problem to Bruce Myren with using quotes in my pre-nav or post-nav text boxes. This video show's what's happening:
http://img191.imageshack.us/img191/3529/8rtj.mp4

The curly quotes aren't working for me.

www.crosbyharbison.com

crosbyharbison
UNITED STATES
6 year(s) ago
Permalink Post

My friend thinks its an issue in regard to magic quotes

adega
SPAIN
6 year(s) ago
Permalink Post

For what i can read is not safe to update to 0.71, is it? or this bug is related with specific hostings?

Thanks,

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

Crosby,

I think you have other things going on as well, your post nav was not loading at all. Looks like you have a mis coded link in there, I got a message saying website could not be found in the post nav box.

If you are on a Mac use the character viewer/keyboard to insert curly quotes. My problem was in titles under images, not in my pre or post nav.

Bruce

Vaska A
UNITED STATES
6 year(s) ago
Permalink Post

I believe I've resolved it - waiting for some feedback. I'll post up the solution once I get some confirmation. Sorry about that...

;)

adega
SPAIN
6 year(s) ago
Permalink Post

Waiting the "0.71a" version ;)

brucemyren
UNITED STATES
6 year(s) ago
Permalink Post

Thanks Vaska!

anpez
ITALY
6 year(s) ago
Permalink Post

Same problem crosby Harbison! ...
www.antoniopezzanofotografo.com

anpez
ITALY
6 year(s) ago
Permalink Post

And the same problem Bruce Myren, I went back to version 0.70d because it is locked more ...
regards

gf
UNITED STATES
6 year(s) ago
Permalink Post

Hi,
Same problem as described by crosbyharbison but in the Pre-Nav Tex.
Website

For your stat.
Thanks.
G.

Vaska A
UNITED STATES
6 year(s) ago
Permalink Post

v72 upgrade files will resolve it. Be sure to read the information.

Showing 1 - 31 of 31 posts in Forum » Announcements » Update to version 71
 

This thread has been closed, thank you.