Indexhibit

Login:

Created by:
Daniel Eatock &
Jeffery Vaska

Built with Indexhibit

Test Slideshow beta 1.2 with us

 

Indexhibit version: 2.0
Thread is resolved.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Hello - today we're making the testing of the new Slideshow format public. We've been doing this behind the scenes the past week and things went quite well. Thanks to the folks who helped out.

Now, you can download Slideshow for Indexhibit 2:

indexhibit.org/downloads/…

How to install...

- put the .js file in /ndxzsite/js/
- put the .css file in /ndxzsite/css/
- put the .php files in /ndxzsite/plugin/

Visit your exhibit via the studio and select Slideshow.

There are both global and exhibit options for this format:

- global option for fade or no fade can be found in Admin > Formats
- local options can be found in Exhibit Options
-- counter and prev/next: none, before or after images
-- placement of body text before or after images

Since this is testing I don't want to hear about feature requests at this time. I actually removed a bunch of new features that will likely find there way into a newer super Slideshow format down the road.

Let's talk about what's in the format right now and how things are working or not.

Thanks

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

I should have added...

- you can click on the image and it will go to the next image (only forwards, not backwards).
- you can use the left and right arrow keys on your keyboard for next and previous too.
- if there is only one image in your exhibit no navigation will appear by default (it's not necessary).
- videos will autoplay in this format - but not the first video.

linuesa
SPAIN
2 year(s) ago
Permalink Post

Thanks for the work Vaska!

In my website, the slideshow 1.2 has some bugs. I think it is due to an incompatibility with my current site customization. For this reason I do not know if I should explain my case here or in a new post. Forgive me if I'm wrong.

This is the site:
linuesa.net/index.php/photo/irrealidades-cotidianas/
I encountered two bugs:

- Clicking on the slideshow project, the first image has the rollover effect that I have given to the home page visual index. I can remove this effect in this case? This is the code on style.css that I think interferes:

  1. /* roll over visual index */
  2. .picture {background:#000000; height: 200px }
  3. a img:hover {opacity:.50; filter:alpha(opacity=50); }
  4. .top a img:hover {opacity:1;}
  5. .picture a:hover {background: none;}

- The following images have the effect of my links (black background). I can delete this on this format?

Everything else seems to work perfectly.
Thank you!

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Yes, those customizations should be made in a much more specific way or it will affect other formats. Take a look at the body tag on any page using visual index and you will see class identifiers that should be used.

lesmineres
SPAIN
2 year(s) ago
Permalink Post

Thanks Vaska!

sthakur
PHILIPPINES
2 year(s) ago
Permalink Post

It seems to be working fine on my site, this page specifically : sonnythakur.com/personal/rodeo-masbateno/

I have a question though, I have resized all files to be 600px height, but because they are of different formats (35mm, 6x7, 6x9 etc.) the slideshow format seems to want to auto resize things. I will double and triple check this and post my feedback right away.

sthakur
PHILIPPINES
2 year(s) ago
Permalink Post

Just tried clicking on fullpx and this time it works. The previous version blew up some images unnecessarily. So far things are fine with mine, no complaints. I will make a new slideshow for videos now and see how it goes. I'll keep you all posted!

Dalton
UNITED KINGDOM
2 year(s) ago
Permalink Post

fantastic!
no problems on my side, thanks so much Vaska!

John

bipster
SPAIN
2 year(s) ago
Permalink Post

No problems here, either. Thanks Vaska!

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Ah yes, fullpx should not be used...

corinnegeney
FRANCE
2 year(s) ago
Permalink Post

Hello Vaska,
i changed the format from "over and over" to "slideshow",
i noticed 2 things about the new format :

– between the menu and the page at its right, the text is not aligned anymore. There is a difference of space at the top.
It doesn't happen if i place the text under the image. : the counter and prev/next stay aligned with the text in the menu.
corinnegeney.fr/index.php/musee-du-louvre/projets-de-mecenat/

– the legend under the image appears in italics (it was in normal with the over and over format).
corinnegeney.fr/index.php/theatre-de-suresnes/communication-saison/

Corinne

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

1. On line 34 (or so) of /ndxzsite/css/overlay.css you can adjust the top margin to zero if you want:

  1. #exhibit .placement-top, #exhibit .placement-bottom { margin: 0.5em 0; }

2. On line 32 of the same file you can take out the font-style:

  1. #exhibit #slideshow .captioning .caption { font-size: 11px; font-style: italic; }

Very good catches, thanks!

oscarito
SPAIN
2 year(s) ago
Permalink Post

Little remark: in the new slideshow people can't rigth-button-save-image-as, or simply drag the images to his desktop, or direct link a particular image... that was a good thing in previous version. You can do that in visual index (permalink mode): useful, cool.

Anyway: this new slideshow is great :-)

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Yes, you can but it's a bit more obscure now. There is a layer over the image/video (for clicking to next) but it does not cover the top and bottom 10% (space that is necessary for video interface sometimes).

Alot of people don't want others to copy images that way, as well. It's a trade-off...

Vassilis
GREECE
2 year(s) ago
Permalink Post

@oscarito this is because of a transparent layer laid over the image to provide the "click on image to go to the next one" functionality. I'm sure you han hide the layer in the slideshow.css with something like:

a#slide-previous, a#slide1000 { display: none; }

...but you'll loose this function and I'm not sure if this breaks the format anyway.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Hiding that would kill the next() function over the image.

We could make that an actual link on the image itself but we'll still have to use the current approach for video. Should we do it that way?

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

I've actually updated my working file with a link (over images) - I think that is the best way to go. Working great...

Vassilis
GREECE
2 year(s) ago
Permalink Post

As Vaska said, many people hate how easy it is to copy images off their website... I personally don't mind (it's easy enough to take a screenshot anyway), I'm just saying they should be considered as well.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

It's a tough one because a person can always make a screenshot or even dig through the code source to get the image. It's for this reason that I don't feel it's worth the effort to prevent people - there is always a way.

It's more fluid and probably semantic using an actual link about the image...

If people are really vociferous perhaps we'll make a different set of formats one day that obscures things from being dragged to desktop.

danwalne
UNITED KINGDOM
2 year(s) ago
Permalink Post

Thanks Vaska,

My previous issue repeated itself so I did a full site re-install and it seems to be working nicely, corinnegeney beat me to the only issue I have noticed so far.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

I've posted a solution for corinne's issue already.

danwalne
UNITED KINGDOM
2 year(s) ago
Permalink Post

Yup. saw it. thanks again.

Hyaku
FRANCE
2 year(s) ago
Permalink Post

Hi there !
For me it's not working.
Here is the page for my test : hyaku.free.fr/index.php/project/t-shirts/
You'll see the problem, nothing happen when i click on the image or on the prev/next.
Thanks in advance !

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

I'll need to look at this more closely but the weekend is upon us...

Hyaku
FRANCE
2 year(s) ago
Permalink Post

Sure it's ok :) it was just to notice.
Have a good week-end all !

ogabriel
BRAZIL
2 year(s) ago
Permalink Post

sorry for the n00b question.. but after installed the format i cannot locate it... am i missing something?

ogabriel
BRAZIL
2 year(s) ago
Permalink Post

sorry for that.. was missing something.. repuloaded all of it.. and its working...

bipster
SPAIN
2 year(s) ago
Permalink Post

Hyaku, your hosting uses PHP 5.1.3 and the Slideshow plugin uses a function (json_encode) which is only available in 5.2.0 and up. I know this because the Firebug extension in Firefox throws the following error:

Fatal error: Call to undefined function json_encode() in /************/ndxzsite/plugin/plugin.jxs_slideshow.php on line 7

Hyaku
FRANCE
2 year(s) ago
Permalink Post

Ola Bipster.
I suspected it, i am going to ask them if a new version is on the way.
Muchas gracias for the confirmation !

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Oh man, need to document that...5.2 and up...

ManonL
FRANCE
2 year(s) ago
Permalink Post

Hi, I have the same problem as Hyaku I think. Only the first picture appears, and then I can't click to the others. I don't understand that PHP 5.2.0 think, where can I change it?

ManonL
FRANCE
2 year(s) ago
Permalink Post

I mean : "that PHP 5.2.0 thing", not "think"

bipster
SPAIN
2 year(s) ago
Permalink Post

ManoL, PHP is the programming language that powers Indexhbit. The Slideshow plugin requires at least the 5.2.0 version of the language in order to work. You should ask your hosting provider to install it.

ManonL
FRANCE
2 year(s) ago
Permalink Post

Hi Bipster. I called them (1and1) and they told me that I was already on the PHP 5.2.17! What can I do then?

bipster
SPAIN
2 year(s) ago
Permalink Post

Can you post the url your site here? Maybe you have a different problem

ManonL
FRANCE
2 year(s) ago
Permalink Post

simulacranostra.fr

bipster
SPAIN
2 year(s) ago
Permalink Post

Where's the project that uses the slideshow format? I only see projects using the over and over format

ManonL
FRANCE
2 year(s) ago
Permalink Post

Yes, it wasn't working so I took it off. I re-put it, see the first one : "Intérieur jour".

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Let me ask you this, are your statistics functioning?

bipster
SPAIN
2 year(s) ago
Permalink Post

Your error is unrelated to the one Hyaku is having. When I click the Prev and Next buttons Firebug throws the following error:

TypeError: html is null
fillShow(html.output, html.height, html.mime);
(simulacranostra.fr/ndxzsite/js/…, line 42)

I don't know what might be happening, sorry. I hope Vaska takes a look.

bipster
SPAIN
2 year(s) ago
Permalink Post

ManonL,

Have you uploaded the plugin.jxs_slideshow.php to the /ndxzsite/plugin/ folder?

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

I believe it's one of two things...

- /ndxzsite/plugin/ajax.php has odd permissions and does not work
- mod_security is blocking us from this particular action

If statistics are functioning then this is clearly a mod_security issue.

ManonL
FRANCE
2 year(s) ago
Permalink Post

No, the statistics until yet weren't functioning.

ManonL
FRANCE
2 year(s) ago
Permalink Post

I mean "aren't functioning".

ManonL
FRANCE
2 year(s) ago
Permalink Post

Ah, yes, it is working!

ManonL
FRANCE
2 year(s) ago
Permalink Post

As you wrote : "put the .php files in /ndxzsite/plugin/"

I put the format.slideshow.php in the plugin, not the other php file!

ManonL
FRANCE
2 year(s) ago
Permalink Post

Thank you very much.

So : the slideshow is now working (that's great!), but not the statistics. It is another problem, isn't it?

bipster
SPAIN
2 year(s) ago
Permalink Post

I'm sorry, I can't help you with the statistics problem.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Have you enabled statistics in Admin > Plugins?

;)

ManonL
FRANCE
2 year(s) ago
Permalink Post

Thank you Vaska!

Showing 1 - 50 of 92 posts in Forum » Customize » Test Slideshow beta 1.2 with us
 

This thread has been closed, thank you.