Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

Godaddy issue, clean URL's and .htaccess troubleshooting

 

Indexhibit version: 2.0
Thread is not resolved.

peternorrman
UNITED STATES
5 year(s) ago
Permalink Post

Hello,

I have done all that i can to enable clean URL's:
- changed the name of the htaccess file to ".htaccess" (with the opening .)
- defined the MODREWRITE to true in the Options file
- tried troubleshooting the .htaccess file in accordance to the help on the Indexhibit site (adding the slash on the last line).
- Modified File Extension Behavior Using the File Extension Manager in Godaddy - unclicked all the FastCGI extensions to noFastCGI.
- Confirmed with Godaddy that they indeed have mod_rewrite

None of this has worked and my URL's are still messy. As a last resort and after reading more of the help files i called Godaddy again to see if they could help me with specific htaccess rules hey might have.

They said they could not help me except pointing me towards some coding sites that sadly make little sense to me.

Is there anyone that has any idea of how i can troubleshoot the .htaccess file so it could possibly work for Godaddy? Seems to me that this is the problem. It could very well be something simple in the code within the .htaccess file - but as I am not good with code, it makes this more tricky for me.

Thanks in advance!

Peter Norrman

ps. my Indexhibit site is a test so far and resides in a test folder.

peternorrman.com/ind/ndxzstudio/

Vaska A
UNITED STATES
5 year(s) ago
Permalink Post

How are you using Indexhibit if you haven't requested or purchased it from our site?

peternorrman
UNITED STATES
5 year(s) ago
Permalink Post

Hello,
I am testing with a copy my wife purchased, to see if it could also work for me.
Apologies if i am sidestepping rules. I was not aware of this as she bought it.
I will purchase it now.
Peter

peternorrman
UNITED STATES
5 year(s) ago
Permalink Post

Purchased.
P.

claurivera
MEXICO
5 year(s) ago
Permalink Post

i think i have the same problem
but a can change the name file of htaccess to .htaccess, how you do that?

arsondpi
GREECE
5 year(s) ago
Permalink Post

You rename the htaccess file with your ftp application.

lemathieu A
FRANCE
5 year(s) ago
Permalink Post

Hello,
you can change the htaccess file name via your ftp app (cyberduck or others) you use to upload Indexhibit content to your hosting space.
Simply add a dot at the start of the name.

edit: late :)

jersmi0
UNITED STATES
4 year(s) ago
Permalink Post

Simply adding the period to .htaccess and following the Help instructions for clean url's did not work for me.

What worked came from here:
support.godaddy.com/groups/go-daddy-customers/forum/topic/mod_rewrite-not-working-on-linux-shared-hosting/

So I added these lines at the end of .htaccess:

#Fix Rewrite
Options -Multiviews

(Can anyone offer an explanation for this? Is it safe? Will it work everywhere?)

 

This thread has been closed, thank you.