Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Google Analytics / not editing from Assets panel

 

Indexhibit version: 2.0
Thread is resolved.

Diego_Shock
UNITED KINGDOM
2 year(s) ago
Permalink Post

Hi there,
I'm trying to add Google analytics to my site.
I have read some forums and from what i can see there are 2 ways.
A) Simply go to Admin->Assets->(template)index.php and paste the google analytics code just before the:


I have tried this but the file wont let me edit it. I have changed permission to 777 but the page stays the same. Is there a way to work this out?
or
B) i have tried to ftp up to index.php file but am not sure as to where it should go .
The path i used was website - ndxzstudio - assets - tpl - index.php
Is this the index.php file to change?

Thanks
D

arsondpi
GREECE
2 year(s) ago
Permalink Post

Actually the index.php of your theme would be something like:
ndxzsite > default (if you're using the default theme that ships with Indexhibit) > index.php

Diego_Shock
UNITED KINGDOM
2 year(s) ago
Permalink Post

Thanks for the advice,
Unfortunately My website stopped working when i edited ndxzsite > default > index.php
do i put the original index.php back in.
Is there any index.php that can be replaced to get this to work .
I am using the Default theme. It says so on my Theme page.
Or even better is there any work around so i can edit this in my Assets panel?

ta,
D

arsondpi
GREECE
2 year(s) ago
Permalink Post

Simply reupload that specific index.php to your server from your computer.

As for accessing the index.php from the Admin area, did you click the save/disk button?

Diego_Shock
UNITED KINGDOM
2 year(s) ago
Permalink Post


I downlaoded the file, edited it accordingly and reuploaded it but for some reason it my site stopped so put unedited index.php back.

When i go to Admin - Assets- templates - index.php
there is no save/disk button or way to edit this file. same as all the files in the Assets area. Where should it be located?
Should something be enabled?

arsondpi
GREECE
2 year(s) ago
Permalink Post

Admin > Assets > theme, index.php
The disk icon (save) should be located in the top right above the text/code window.

Diego_Shock
UNITED KINGDOM
2 year(s) ago
Permalink Post

When I go into Admin-Assets- there is no theme, it just says this on the left had side of the window which i assume is the template theme.

Template (default)
base.css
ie.css
index.php
media.php
reset.css
style.css
tag.php
error.php

When i click on index.php
i get this





: {{obj_name}}











{{obj_itop}}

{{obj_ibot}}










i believe that the relevant analytic code goes just before at the end. However i cannot edit this file and there is no save icon on this page.
I am starting to guess that there was a breakdown in the original ftp . Any ideas?

Best Answer!
Diego_Shock
UNITED KINGDOM
2 year(s) ago
Permalink Post

so , i ftp'ed up to
ndxzsite > default> index.php
Changed the file setting to 777
and the file/save button appeared on the index.php page in assets. I
added the relevant analytic text and saved it.
My site didnt work for some reason. I downloaded the index.php file from the path above and all the text had disappeared unusual as i could see it in the Assets>index.php page !
Anyway, I uploaded a new index.php file with the analytic text added and all is working fine again.
Thanks for your help and direction to the file.

D

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Cool. Use of the Assets section is a bit advanced - people should only be using that if they understand what they are doing.

 

This thread has been closed, thank you.