Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

indexpand not working ONLY on the main page

 

Indexhibit version: 2.0
Thread is not resolved.

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

Hi lovely people

I just finished the website I am working on for a client, everything works fine now, except that the indexpand plug in keeps all the menus open ONLY on the main page, if i go on other pages the menus open and close correctly instead.

Any ideas where I can fix this and why does it happen?

thanks in advance

Anto

the website is: marcheseditore.com/

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

Which account is your clients Indexhibit registered to?

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

my indexhibit installed on a myhosting.com server, is this what you are asking?

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

So, you use Indexhibit for free for yourself and your "clients" (who even have an online shop)?

How would you like us to continue Indexhibit?

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

I am happy to do a contribution if this is what you mean, it is an Italian client and he pays me not much more of what you are suggesting for a professional use, and I am not a web designer, I just try to learn. I know the all thing it s not an ideal situation but unfortunately this is my situation at the moment.

Anyway I will do a contribution wheter you help me or not with my issue, it is only right.

thanks in any case for your work.

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

I just did an individual contribution, thanks for your support, and apologise again to not have done this before. I hope to be able to afford more contribution next time I use Indexhibit

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

is it possible to take a look at my issue anyway? thanks

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

Clients and free isn't really fair. People should simply build in that cost and have the client pay for it. If we knew how to make this be the case this project would be doing much better - but people do it and don't support us and it's not helping.

The problem with your site is that you haven't setup clean url's properly - there is a tutorial in the Help section abou this.

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

thank you very much Vaska, I agree with your point about clients and free, I am working hard to make it change. As I said I will be more then happy to contribute to Indexhibit in the future when I will keep using it.

Thanks for everything

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

The problem with your site is that you haven't setup clean url's properly - there is a tutorial in the Help section abou this.

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

I cleaned the url but the Indexhpand plugin still is works on all the pages and not on the main paga, is it a common issue of the plugin maybe? did someone experienced it before?

arsondpi
GREECE
1 year(s) ago
Permalink Post

If you mean that the CONTATTI page is not working then you should exclude this section from Admin > Plugins > Indexpand, Options

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

I did this, but the problem I was describing is that as I set the 'pubblicazioni' page as main page (home page), on that page the expanding menus are all open, and even if i click on them they don t close. I d like them to be all closed and only open if the user click on it to discover the link to the other sections.

arsondpi
GREECE
1 year(s) ago
Permalink Post

Did you search the forum at all?
I think for example that this thread maybe of help: indexhibit.org/forum/thread/18136/

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

thanks, I did actually, and i was able to modify some setting, but I don t find where I control what I need. so at the moment all the expanded menus are open on the main page, and they don t collapse at all, whereas when I go on the other pages the menu works perfectly.

Any suggestion where to put my hands?

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

I'm not sure what's going on there yet. Disable the moveup plugin - you don't need it with this format.

I'm not getting any javascript errors in the console - it's strange.

CONTAMINAZIONI
UNITED KINGDOM
1 year(s) ago
Permalink Post

I did, still the same, it s really weird is only on the main page.

I set as a main not the homepage of my domain, and even if i change main page I still experience the issue on whatever page I set as main,

Showing 1 - 17 of 17 posts in Forum » Customize » indexpand not working ONLY on the main page
 

This thread has been closed, thank you.