Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Upload File Size

 

Indexhibit version: 2.0
Thread is not resolved.

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I'm having trouble uploading any large files up to my gallery. I read that this is an issue with the php.ini file, so I just had it bumped up to allow 2 gigs for the max upload, but Indexhibit is still not recognizing the increased file size and won't let me upload. ANhosting is my webhost, if that helps at all.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

2 gigs is way too big - and it will likely fail via your hosting defaults as well.

Try a smaller image - like around 500kb and see how it goes.

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I changed the max file size to about 400M in the php and it's still not working.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

How big was the image? What happens when you try to upload?

Wait, did you enter 400M into the variable?

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

The image was about 400kb, and when my file limit was pushed to 2 gigs it was listed as 2000M in the variable?

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Why would you put 2000M? It's numbers only...'2000' would have been sufficient.

2800 is 2MB. And that, would be a huge image to upload to your server and your webhost might not even allow it.

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I've switched the variable to 500 and it will still not upload a 250 kb file.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

When you say "will not" - what is happening?

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I'm getting an error in Indexhibit saying: Error File too big.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Try to upload a tiny tiny file.

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

Files under 200kb seem to be uploading just fine.

srge
BAHRAIN
2 year(s) ago
Permalink Post

same with me. I changed the config.php file in the line 13, to 2000 instead of 200 but won't upload images that are 205kb, for example..
where else to change it?

srge
BAHRAIN
2 year(s) ago
Permalink Post

sorry, wasn't in the config.php, I changed it in the "options.php"

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Are you sure the change is saving to the file?
Are you positive the image is the right size?
What browser are you using?

srge
BAHRAIN
2 year(s) ago
Permalink Post

I changed the right file and I'm positive that is saved, as I downloaded the file again from the FTP and has the changes. Is the options.php. It happened to me with many different images. I resized the images to be smaller than 200kb and they work.
I tried it with Chrome, Safari and Firefox. Always same mistake.

And I know the forum rules, I've been using indexhibit for the last 6 years and now bought the new version, and will keep buying upgrades, because I appreciate the effort and the quality. But I also appreciate kindness of treatment. You closed the other post but I couldn't fin a solution yet in any other thread. Please don't be so rude and don't underestimate the people that trusts you.
And please help me solve this, if you don't mind. Thanks
Sergio

srge
BAHRAIN
2 year(s) ago
Permalink Post

I spent the day reviewing for the information on my server, but couldn't find it. Finally re installed and problem was solved. Thanks everyone anyways.
srge

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

srge - it's forum ettiquette to not post the same question more than once. it's like this in all forums. i'm not being rude. i'm trying to keep quality in this forum - otherwise we end up with lots of threads that don't have answers for something that was already asked and answered in another thread.

what are you using to edit your files with (ftp and a text editor, coda, etc)?

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I'm sure the change is being saved to the file and that the sizes are correct for the images. I'm using Chrome. To edit the php.ini file I'm using the editor within my cpanel's file manager.

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I've gone back and forth between my webhost and they've assured me that the file limit has been increased correctly in my php.ini file, so it's something in indexhibit. Where is the config.php file to edit?

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

/ndxzsite/config/config.php

Use ftp and a text editor only for this.

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I get a 404 internal server error.

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

Or, rather, 500 Internal Server Error.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Not if your site is installed - that's not possible. Use your FTP app.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

I think you might have a bunch of messed up permissions...

cdacanay
UNITED STATES
2 year(s) ago
Permalink Post

I've edited the max file size in options.php and now I'm getting an Empty File Upload error, even with small images that uploaded previously.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

I would start over - reinstall and don't change anything until you know uploading works. Something has really gone wrong here - it's just not this difficult for this to be working.

mspygmy
UNITED STATES
2 year(s) ago
Permalink Post

Try using another browser. I had the same issue. Firefox has an upload security measure of under 200px. I think this might be true for chrome as well. I successfully upload 500mb+ files using Exporter-it's the only thing Explorer is good for. This happens with customizable eCommerce sites as well.

Vaska A
UNITED STATES
2 year(s) ago
Permalink Post

Clear the browser cache (shift + refresh). I had the exact same problem today and that cleared it right away.

You can't upload a 500mb file to a portfolio site - it's not an option.

Showing 1 - 28 of 28 posts in Forum » Customize » Upload File Size
 

This thread has been closed, thank you.