Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Fatal Error: index.php on line 10

 

Indexhibit version: 2.0
Thread is resolved.

michelleamosu
UNITED KINGDOM
2 year(s) ago
Permalink Post

Please help!

I am new to indexhibit and was having a look at some threads on the forum about trying to insert a logo in the pre-nav box. I tried uploading my logo at my host (awardspace free account) but couldn't find a path/url that worked, so I uploaded my logo (jpeg) onto photobucket. I used the following html code and dropped it into the pre-nav box:

< img scr= 'i1286.photobucket.com/albums/a609/michelleamosu/…' />

I clicked 'update' and it took me to a error 404 page from my web host. I then tried to find my website michelleamosu.co.uk/ and this message came up:

Warning: require_once(ndxzstudio/defaults.php) [function.require-once]: failed to open stream: No such file or directory in /srv/disk1/1422443/www/michelleamosu.co.uk/index.php on line 10

Fatal error: require_once() [function.require]: Failed opening required 'ndxzstudio/defaults.php' (include_path='.:/usr/local/php-5.3.22/share/pear') in /srv/disk1/1422443/www/michelleamosu.co.uk/index.php on line 10

Please help, I have gone down so many avenues over the past few weeks with trying to build a portfolio website for my degree show now at the end of this week, I finally find and love indexhibit and this has just happened! Has my website been deleted? Any advice would be a great help.

Thank you in advance!

michelleamosu
UNITED KINGDOM
2 year(s) ago
Permalink Post

sorry in the html code I did include the http:// before the address for the image.

arsondpi
GREECE
2 year(s) ago
Permalink Post

The error message means that defaults.php is missing.
Can you check that it's there? (ndxzstudio/defaults.php)
If it's not you should reupload it.

Also for your logo there are other ways to around things.
I've posted a few solutions here - do check the links posted in that thread as well.
indexhibit.org/forum/thread/19060/

michelleamosu
UNITED KINGDOM
2 year(s) ago
Permalink Post

Hi arsondpi,

Thanks for your response. I had a read of a few forums, and figured that I should try to reupload the ndxzstudio folder. I discovered that somehow the folder was not where it was meant to be and found the folder within the ndxsite/js/ folder! I couldn't figure out how to move the folder out to where it belonged, so I copied the folder to my computer and deleted it on cyber duck. I then tried to drag it onto cyberduck but I got the following message from cyber duck's transfer dialog box"

"FTP Error: Cannot create folder ndxzstudio
/ndxzstudio

550 /ndxzstudio: Permission denied."

was this totally the wrong way to re-upload?

I do not have a back up of my website as I had used a free web host with this feature not included.

What should I do? Have I done enough damage and should I just start over? If so how do I uninstall and reinstall indexhibit?

I'm sorry I seem to be so clueless, everything was going fine until well, it wasn't! I appreciate your help, please tell me what you think I should do next.

Best Answer!
michelleamosu
UNITED KINGDOM
2 year(s) ago
Permalink Post

Okay amazing! I managed to get the website back up and running! Cyberduck seemed to continue to disallow me to reupload, so I switched to filezilla ftp client. I reuploaded the ndxzstudio folder and its back! Thank you for you're help and I will check out the logo thread you posted.

Showing 1 - 5 of 5 posts in Forum » Customize » Fatal Error: index.php on line 10
 

This thread has been closed, thank you.