Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

was working, now says "no input file specified"?

 

Indexhibit version: 2.0
Thread is not resolved.

annabeth
UNITED STATES
4 year(s) ago
Permalink Post

Hi,
My website was until very recently working fine. I hadn't done anything to it in the last six months, and after just checking it from various computers when you click on my images, as well as the link to download my CV, and get my email address it says "no input file specified". In my management of pages all of the images and links are still in there.... not sure where to go from here, can you help?
Thanks a lot,
A

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

It sounds like something happened to your .htaccess file - is it still there?

jersmi0
UNITED STATES
4 year(s) ago
Permalink Post

Me, too!

htaccess is in the my root folder. Downloading and opening in Text Edit shows:
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.+) - [PT,L]
RewriteRule ^(.+) index.php

jersmi0
UNITED STATES
4 year(s) ago
Permalink Post

Problem with index.php?

jersmi0
UNITED STATES
4 year(s) ago
Permalink Post

/ndxzstudio control panel loads fine.

arsondpi
GREECE
4 year(s) ago
Permalink Post

jersmi0 there's so many threads around about this indexhibit.org/forum/search/
It is usually related to an .htaccess issue

jersmi0
UNITED STATES
4 year(s) ago
Permalink Post

Ah, sorry, first one I saw, and fresh, I'll look around.

jersmi0
UNITED STATES
4 year(s) ago
Permalink Post

Hi annabeth,
I'm on godaddy, got mine working:
indexhibit.org/forum/thread/18685/

spideretc
UNITED STATES
4 year(s) ago
Permalink Post

hi guys, i'm helping annabeth with fixing her website....

i edited the .htaccess file as speicified, it now looks exactly like this:
#Fix Rewrite
Options -Multiviews

RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.+) - [PT,L]
RewriteRule ^(.+) index.php

it seems nothing has changed.

the front index.php page works fine, but whenever you click a link it (as we're all familiar) "no input file specified", but if you delete index.php from the subsequent url, you desired page arrives. i can't figure out how to edit the links in the sidebar to remove index.php from the url. right now all urls are set up in this format:

annabethmarks.info/index.php/project/ii/
but we need them to be like this:
annabethmarks.info/project/ii/

if you want to take a peek, the website is annabethmarks.info/

do i need to edit one of the rewrite rules?

arsondpi
GREECE
4 year(s) ago
Permalink Post

Did you tell GoDaddy? Can they help you out with this? Maybe it's a server specific setting they have...

spideretc
UNITED STATES
4 year(s) ago
Permalink Post

she called go daddy, they said it was her problem. i feel like it must be a server problem since annabeth didn't touch anything. but go daddy doesn't have very good tech support...... so if there's something i can do to avoid spending hours on the phone with them i'd love to do it.

spideretc
UNITED STATES
4 year(s) ago
Permalink Post

she called go daddy, they said it was her problem. i feel like it must be a server problem since annabeth didn't touch anything. but go daddy doesn't have very good tech support...... so if there's something i can do to avoid spending hours on the phone with them i'd love to do it.

 

This thread has been closed, thank you.