Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

filesource class not found

 

Indexhibit version: 2.0
Thread is not resolved.

gd
UNITED STATES
4 year(s) ago
Permalink Post

I spent some time looking at previous threads before posting this.
I really spend some time trying to solve it myself.
It is not the first time I install Indexhibit.
Been using it since the very beginning.

"filesource class not found"

This time I used Mac OSX Mavericks "built-in" local server.
Everything works fine but as soon as I try to create a new exhibition it 'goes crazy'

Also noticed that I can't rename a section and save it. It just doesn't save.

If anyone has an idea, would be appreciated :-)
THANKS!
D

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

I'm using the same with no problems for development.

Are you sure all the files are there? Reupload /ndxzstudio/lib/ folder.

gd
UNITED STATES
4 year(s) ago
Permalink Post

Thanks for your answer Vaska.
I tried this but no success :-( :-(

gd
UNITED STATES
4 year(s) ago
Permalink Post

Anyone else had this problem already?

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

Yes, I've seen the problem before but not on a local machine.

What is the default encoding for your mysql installation? It should be utf8 something...

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

Also, which version of PHP are you running?

gd
UNITED STATES
4 year(s) ago
Permalink Post

Server: Localhost via UNIX socket
Server type: MySQL
Server version: 5.6.15 - MySQL Community Server (GPL)
Protocol version: 10
User: root@localhost
Server charset: UTF-8 Unicode (utf8)

Apache/2.2.24 (Unix) DAV/2 PHP/5.4.17 mod_ssl/2.2.24 OpenSSL/0.9.8y

myphp:
Version information: 4.1.5, latest stable version: 4.1.6, latest stable version: 4.1.6

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

Does the db user have all privileges?

I'm not really sure what to say here...supporting local installs is something we've never done because they can be quite different.

gd
UNITED STATES
4 year(s) ago
Permalink Post

yep...

grrr

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

grrr...we've never been able to support local installs. we've always been explicit about this around here from day one.

gd
UNITED STATES
4 year(s) ago
Permalink Post

Is there any other way I can work locally you think?

gd
UNITED STATES
4 year(s) ago
Permalink Post

of course; not blaming the indexhibit forum at all.
just grrrrrrrrrrrrrrrrrr hehe

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

it works just great on my brand new macbook pro - no problems whatsoever. so, it's possible...

i'm using the stock version of PHP it shipped with and i had to compile mysql into things. which is always some voodoo...

it's all about the setup and this is something i'm not an expert at.

gd
UNITED STATES
4 year(s) ago
Permalink Post

hmmm.
just realized the 'server connection collation' is set to utf8mb4_unicode_ci.
Should it be only utf8_unicode_ci?

( if it is the case, I'm not able to change it in phpmyadmin... weird )

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

that is likely the problem.

what i have seen before is that if the collation is something weird, or simply different, you can have this problem.

very weird that you are unable to change it. or, did you go...by database...by table...and by every individual column? because, that's what you'll need to do.

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

i hope it works. beyond what i've said already, i'm stumped.

gd
UNITED STATES
4 year(s) ago
Permalink Post

Actually every single table is set to utf8_unicode_ci

But on the main phpmyadmin page:
'server connection collation' dropdown menu indicates 'utf8mb4_unicode_ci'

When I change it to 'utf8_unicode_ci' it 'loads' but then 'utfo8mb4_unicode_ci' reappears :-/ hehe

Is there a better way to change this? manually? query?

gd
UNITED STATES
4 year(s) ago
Permalink Post

tell me if 'paid assistance' applies in this situation.

thanks in advance,
D

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

but i can't work on your computer - this is one of the reasons we don't support local installations. i know alot about servers but i'm not an expert at this kind of problem.

oddly, mine too is utfo8mb4. i'll run some tests tomorrow - right now i'm trying to focus on some big things.

iharsuvorau
BELARUS
3 year(s) ago
Permalink Post

Hello, guys. I have the same issue now. Have you solved the problem?

Vaska A
UNITED STATES
3 year(s) ago
Permalink Post

It's installed on your own computer, as well?

iharsuvorau
BELARUS
3 year(s) ago
Permalink Post

Yes, os x 10.9.5 macbook pro.

  1. Database server
  2. Server: Localhost via UNIX socket
  3. Server type: MySQL
  4. Server version: 5.6.21 - MySQL Community Server (GPL)
  5. Protocol version: 10
  6. User: root@localhost
  7. Server charset: UTF-8 Unicode (utf8)
  1. Web server
  2. Apache/2.2.26 (Unix) DAV/2 PHP/5.4.30 mod_ssl/2.2.26 OpenSSL/0.9.8za
  3. Database client version: libmysql - mysqlnd 5.0.10 - 20111026 - $Id: c85105d7c6f7d70d609bb4c000257868a40840ab $
  4. PHP extension: mysqli

I've changed 'collation' for every ndxzbt_* table from latin1_swedish_ci (default) to utf8_general_ci — still the problem.

Changed default collation for DB to utf8 — also doesn't work.

Vaska A
UNITED STATES
3 year(s) ago
Permalink Post

Ok, first of all, I don't support these installations because there are many things that can go wrong - that I don't know about.

That being said, what you are doing is right, but there is a server setting you need to adjust. I'm trying to remember what is it...

I believe it's in php.ini and it's a simple thing that...does...something. Fixed it right away for me.

Vaska A
UNITED STATES
3 year(s) ago
Permalink Post

It doesn't concern *.sock, I think. Just curious if you tried this...

"And finally, a note on character sets. If you know — or even think — you might work with characters outside the English language, then it’s a good idea to set your MySQL server, database, client, and connection character sets now. Create a file called my.cnf and place it in /etc. In it, put the following:

[mysqld]
collation-server = utf8_unicode_ci
init-connect = 'SET NAMES utf8'
character-set-server = utf8

Vaska A
UNITED STATES
3 year(s) ago
Permalink Post

I can't find it. I knew when I did this that if I lost that bookmark I would be sorry...

iharsuvorau
BELARUS
3 year(s) ago
Permalink Post

Vaska, I understand about support. Thank you for your concern.

I've just tried your edits about [mysqld] — doesn't work.
I have this config file in /usr/local/mysql/my.cnf. I copied it to /etc too. Add these lines. Also created new DB with
* default collation: utf8_unicode_ci
* default characterset: utf8
* every table has collation utf8_unicode_ci and characterset utf8 too
* engine type: InnoDB

Still doesn't work :(

Vaska A
UNITED STATES
3 year(s) ago
Permalink Post

None of those are what you want. It's a super obscure thing affecting the database...I just can't remember what it was...

iharsuvorau
BELARUS
3 year(s) ago
Permalink Post

Nice :)
Maybe some day you will remember and we could write the solution in BOLD CAPSLOCK. Anyway, if I find something I'll write.

yukao
HONG KONG
2 year(s) ago
Permalink Post

Hello, I am having the same problem. I tried changing the "server connection collation" in phpmyadmin to utf8_unicode_ci, but it automatically switched back to utf8mb4_unicode_ci. After a bit of research, I found that this behaviour was made intentionally.

github.com/phpmyadmin/phpmyadmin/commit/…

Showing 1 - 29 of 29 posts in Forum » Installation » filesource class not found
 

This thread has been closed, thank you.