Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

Error 500 after server upgrade (htaccess problem), host is no help

 

Indexhibit version: 2.0
Thread is not resolved.

robbg439
UNITED STATES
2 year(s) ago
Permalink Post

My site started returning an Error 500 after my host did a server upgrade. I made no changes or additions to the site between when it was working and when it wasn't. If I disable the htaccess file and turn off clean urls, the site starts working again.

I've asked my host multiple times if anything was changed as a result of the server upgrade, and they said no. They suggested that maybe some part of my site had written to the htaccess file, but I have uploaded a new, clean version of it, and it didn't change anything. They said that maybe the software I was running or a plugin had updated automatically without my knowing, which I know isn't true. They said there was no sign of hacking, and told me to talk to a developer. Any ideas?

pepe
SPAIN
2 year(s) ago
Permalink Post

Hi, I have exactly the same problem. I posted it here:

indexhibit.org/forum/thread/22423/

The only thing my host changed was the server and an upgrade from Apache 1.8 to Apache 2.4.18.

pepe
SPAIN
2 year(s) ago
Permalink Post

Hi robbg439

I've solved the problem ten minutes ago.

I've rewritted the htaccess with this code:

  1. <IfModule mod_rewrite.c>
  2. RewriteEngine On
  3. RewriteBase /
  4. RewriteRule ^index.php$ - [L]
  5. RewriteCond %{REQUEST_FILENAME} !-f
  6. RewriteCond %{REQUEST_FILENAME} !-d
  7. RewriteRule . /index.php [L]
  8. </IfModule>

It has worked for me.

 

This thread has been closed, thank you.