Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

config.php

 

Indexhibit version: Legacy
Thread is not resolved.

vangogh07
GERMANY
5 year(s) ago
Permalink Post

i just try to install indexhibit.

after i entered the name of the database/-name/etc. …
i get the message that i have to check "config.php"… but i can't find it on the server…
inside of the "config"-folder there's just a "config.example.php"…

who can help me out?

Vaska A
UNITED STATES
5 year(s) ago
Permalink Post

Let me guess, you reinstalled?

james_stanton
AUSTRALIA
5 year(s) ago
Permalink Post

"config.example.php"… is the example just copy it delete the word example eg config.php and then correct all the info.

so on

didith
UNITED KINGDOM
5 year(s) ago
Permalink Post

hello!
I just have the same problem and thought, this (see above) is the right answer I need, BUT...

I get this message when I change the file into 'config.php':
'You need to delete the /ndxz-studio/config/config.php file if you wish to install Indexhibit.'

Can anybody help me?
Thanks!
Edith

Vaska A
UNITED STATES
5 year(s) ago
Permalink Post

What are you trying to do? If you are already ready installed then you need to delete the install.php file (as it says in the instructions). If you are trying to reinstall you need to delete the config.php file.

This is a security measure...

didith
UNITED KINGDOM
5 year(s) ago
Permalink Post

hello!

I try to rename config.example.php into config.php.
I know that I have to delete the install.php file, but I don't come so far, because of this message:
'You need to delete the /ndxz-studio/config/config.php file if you wish to install Indexhibit.'

If I delete the config.php file from the config map I get this message: Bitte ueberpruefen Sie die Einstellungen der Datei config.php. = Check preferences on file config.php

How can I change config.example.php into config.php so that I don't get this message again?
Cause, this file I need in any case, right?

Vaska A
UNITED STATES
5 year(s) ago
Permalink Post

I don't understand why you would even need to make this change.

didith
UNITED KINGDOM
5 year(s) ago
Permalink Post

after i entered the name of the database/-name/etc. …
i get the message that i have to check "config.php"… but i can't find it on the server…
inside of the "config"-folder there's just a "config.example.php"…
i put the value on 777, so this is not the problem.

so, i do not need to change the name.
but what else do i have to do?

it's not about the install.php file cause i still stuck with the message that i have to check "config.php".


mstemmelen
UNITED STATES
4 year(s) ago
Permalink Post

I have installed my database name, username, password...etc.
I haven't placed any content on my site yet.
When I open my browser (Firefox) where do I login to my Indexhibit website (to keep posting content)?
If this is the way to login to keep editing: http://www.mywebsite.com/ndxz-studio/install.php
well then I get this error message:
""You need to delete the /ndxz-studio/config/config.php file if you wish to install Indexhibit.""
I thought I was done 'installing' Indexhibit, I was just trying to edit my site at this point.

Did anybody encounter this problem?
Thanks for any help you can bring me.

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

You are done. If you wish to re-install. When you are done, you delete that file...you should not see that note...because you are done and you have deleted the install.php file.

cchhrriissttoopphh
GERMANY
4 year(s) ago
Permalink Post

Excactly the same problem occured to me when I tryed to install indexhibit for the very first time.(Check preferences on file config.php)

Now, a few hours later, on install page 2 I'm being asked to check my config settings again. Who can help me out?

mstemmelen
UNITED STATES
4 year(s) ago
Permalink Post

Thanks for your reply.
I went ahead an deleted /ndxz-studio/config/config.php file (in Cyberduck)

I was able to login, and this is what I got:

"Indexhibit

OK Looks like the database is ready.

The default login / password is index1 / exhibit.

Change these and your site settings once inside.

Let's login!

Delete the install.php file from your site."

And when I went into Cyberduck to delete this 'install.php' file, I was completely erased from my Indexhibit site (I had to reinstall it).
Can you help me?
Thanks-

arsondpi
GREECE
4 year(s) ago
Permalink Post

I'm not sure I understand very well... are you after reinstalling instructions?

mstemmelen
UNITED STATES
4 year(s) ago
Permalink Post

Well it's not telling me to delete the install.php file from my site anymore, so I should be good ;) thanks!

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

Well, you still need to delete it...

cchhrriissttoopphh
GERMANY
4 year(s) ago
Permalink Post

Hello again,

I'd realy like to solve my problem.

What am I to do when on installation page 2, after I press the "submit"-button, it says "XX Please check your config settings again."?

Thanks.

bryanjrod
UNITED STATES
4 year(s) ago
Permalink Post

I am having the exact same installation problem.

Everything has been uploaded to the server, permissions have been changed, language selected on ndxz-studio//install.php page. All is confirmed writeable:

OK /files folder is writable...
OK /files/gimgs folder is writable...
OK /ndxz-studio/config folder is writable...

Let's try to set up the database now.

..and so I "try to setup database now" and enter in relevant information. Database was setup by webhost and I have the correct database name, username, and password. And yet, as with others here, this message appears:

XX Please check your config settings again.

So I go poke around the config file which is called config.example.php Tried changing permissions, changing name of file with the same results as described above.

The install.php file can't be deleted until this successfully installs so that isn't the problem either.

Could use some help on this as I am doing this solely for the sake of making a tutorial video to show others how to install indexhibit, so this is a problem they may encounter and it will be good to troubleshoot this on the video. php/database geniuses out there perhaps?

Any help appreciated.

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

Technically, you need to install the tables into the database...if your database connection into is correct (check with your webhost) it will work.

bryanjrod
UNITED STATES
4 year(s) ago
Permalink Post

I may have figured this out. In my case, the problem was the "Database Server" field. It comes in with localhost as the default. This has to be changed to whatever is correct for your server. In my case at webhero it's "mysql.webhero.com". Of course I screwed it up from there by hitting the backbutton before deleting my install.php I'm going to reinstall and try again. Will report back.

bryanjrod
UNITED STATES
4 year(s) ago
Permalink Post

Totally worked! That was it, I answered my own question out of pure luck. I hope this works for others. To reiterate my solution:

Change field for Database Server from default "localhost"
to whatever is the phpadmin page for your host.
Mine was mysql.webhero.com

I will post my video tutorial on youtube and link it here.

kevissimo
UNITED STATES
4 year(s) ago
Permalink Post

Ok I am having a similar problem except that after all of the permissions have been changed and I filled out the fields at the my_site/ndxz-studio/install.php

I get 'XX We cannot connect or install the database.' then entering this I get
'You need to delete the /ndxz-studio/config/config.php file if you wish to install Indexhibit.'

So I delete the file. Then config.php reloads back into the folder and I'm stuck in a loop.

I've used both "localhost" and my phpadmin info in the database server field and get the same result.

Any help is appreciated...

aust
UNITED STATES
4 year(s) ago
Permalink Post

I filled out the fields at the my_site/ndxz-studio/install.php

I get 'XX We cannot connect or install the database.' then entering this I get
'You need to delete the /ndxz-studio/config/config.php file if you wish to install Indexhibit.'

So I delete the file. Then config.php reloads back into the folder and I'm stuck in a loop.

Any help is appreciated...please

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

No, because if you would read what it says after you install...the first thing it says is delete the install.php file. So, you should not see the delete the config.php note.

Don't delete config.php...ever. Unless you are reintstalling.

aust
UNITED STATES
4 year(s) ago
Permalink Post

hello , sorry to bother u again

It appears " XX ,We cannot connect or install the database."

My host is fatcow

aust
UNITED STATES
4 year(s) ago
Permalink Post

hello , sorry to bother u again

It appears " XX ,We cannot connect or install the database."

My host is fatcow

aust
UNITED STATES
4 year(s) ago
Permalink Post

hello , sorry to bother u again

It appears " XX ,We cannot connect or install the database."

My host is fatcow

aust
UNITED STATES
4 year(s) ago
Permalink Post

hello , sorry to bother u again

It appears " XX ,We cannot connect or install the database."

My host is fatcow

aust
UNITED STATES
4 year(s) ago
Permalink Post

hello , sorry to bother u again
(i'm so sorry about the same post upside..)

It appears " XX ,We cannot connect or install the database."

My host is fatcow
and there is a "Server Name"in fatcow mySQL page

called "austinchancom.fatcowmysql.com"

Does that mean "austinchancom.fatcowmysql.com" is what I should fill in Database Server?

moshr00m
SLOVENIA
4 year(s) ago
Permalink Post

no, I have the same "loop" problem, and I'm sure it says "delete config" not "install" file. ..

moshr00m
SLOVENIA
4 year(s) ago
Permalink Post

no, I have the same "loop" problem, and I'm sure it says "delete config" not "install" file. ..

moshr00m
SLOVENIA
4 year(s) ago
Permalink Post

no, I have the same "loop" problem, and I'm sure it says "delete config" not "install" file. ..

Showing 1 - 31 of 34 posts in Forum » Installation » config.php
 

This thread has been closed, thank you.