Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

All pages have No input file specified.

 

Indexhibit version: 2.0
Thread is resolved.

hugonadeau2
CANADA
5 year(s) ago
Permalink Post

Hi there,

I successfully installed Indexhibit and changed my index and created contents to some pages. Unfortunalty, all pages show only "No input file specified" error message when I click on index link, even if there is a saved message in the indexhibit admin site. That same message works fine when I select the option to make the page as the home page.

What can it be?

hugonadeau2
CANADA
5 year(s) ago
Permalink Post

My link is here : hugonadeau2.com/

arsondpi
GREECE
5 year(s) ago
Permalink Post

It sounds like an htaccess issue. Have you enabled clean urls (as described here: indexhibit.org/tutorials/getting-started/enable-clean-urls/) correctly?

There's answers in the forum that may be of help: indexhibit.org/forum/search/

chiaozza
UNITED STATES
5 year(s) ago
Permalink Post

Hi, I am having the same issue. The two-deep links lead to an "internal server error" page (originally said "no input file specified" but then changed once I started fiddling around).

I have searched the forum and read the threads related to the topic and nothing has quite worked for me, including trying to enable clean URLs by changing MODREWRITE to true in options.php, adding the / to my htaccess file, and changing my php options in godaddy. I tried renaming the htaccess file in my root folder to .htaccess, but Cyberduck doesn't seem to recognize the change, or maybe it does, but it still looks like htaccess. I'm running out of ideas.

I am new to Indexhibit v2 and have very little programming experience, so step by step answers would be the most helpful to keep the threads shorter.

My site, chiaozza.com, is being hosted under eternitystew.com, so the URL looks like this: chiaozza.eternitystew.com.

Thanks in advance for any tips.

chiaozza
UNITED STATES
5 year(s) ago
Permalink Post

A-ha! It seems I didn't completely "unhide" my hidden files like I thought I did on my FTP browser (Cyberduck). The setting had to be changed in "Preferences" to show hidden files as well as in my "View" menu. It seems I was editing the htaccess file without the . in front, not the .htaccess, which was hidden.

 

This thread has been closed, thank you.