Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

RoyalSlider + indexhibit = perfect but one issue

 

Indexhibit version: 2.0
Thread is not resolved.

fransvax
UNITED STATES
1 year(s) ago
Permalink Post

I use royal slider ( dimsemenov.com/plugins/royal-slider/ ) on my (in construction) website and it works like a charm except with a little issue when exiting a full screen vimeo video (in html5, not flash). Then, the slider "dissapear" because he doesn't know what dimension to go in. Exemple here: division41.com/index.php/project/corporate/
Note that with youtube videos on the other slides, there is no problem.

Dmitry who did the royal slider tried to help me ( help.dimsemenov.com/discussions/problems/… )but it looks like the issue is linked to indexhibit... so maybe someone can have a look and see if he has an answer to my problem? it would be great! Except this issue, royal slider and indexhibit are perfect together!

Thanks!

Francois

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

Please post your question/problem here - we're not going to another forum to look up things up.

RS is nice, but it's also rather slick. Most people at Indexhibit want even more simplicity...might be nice to vastly reduce the design.

fransvax
UNITED STATES
1 year(s) ago
Permalink Post

Ok, let me try to explain the problem here then.

As you can see here: division41.com/index.php/project/corporate/

When you start the video, go into full screen then exit the full screen mode, the slider "disappear" somewhere... the sound is still playing so I suppose it's invisible because of some dimension issue. Dmitry says: "Slider code that gets height is pretty straightforward, but for some reason it returns 0 after exiting fs."

Notice that the issue appears ONLY in Chrome and ONLY if you use the html5 player of Vimeo.

Also, using this html page that Dmitry submitted to me, it works like a charm...
the html basically puts the whole slider just after the tag.

view-source:s3.amazonaws.com/entp-tender-production/assets/f7d8690f0aac96ee63d83e28b32e60aa7a16fdc8/…

Any idea of what might go wrong?

fransvax
UNITED STATES
1 year(s) ago
Permalink Post

(the html page puts the whole slider after the BODY tag)

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

What is the slider? I don't see a slider - I see arrows for right and left and some clickable dock thing at the bottom (which is terribly difficult to use).

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

I'm thinking about this. Don't you need to install a plugin to make Chrome default to html5 display? Thing is, there is so much stuff going on here, I don't really see how this is an Indexhibit issue - the bug doesn't lie with us. People may need to customize this player to work well with it - because I can see that the left arrow button lies under the #index (and also it would look strange for it to ride over the text as well).

I wish I could take code from anyplace and dump into where ever I want, but that doesn't mean it will work perfectly.

The nice thing about writing an exhibit format for Indexhibit is that you have quite alot of room to play with js and css in addition to everything else.

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

And, last comment, I too have struggled with controlling Vimeo's player (in a differrent situation) - I had to write some silly code to make it behave properly. This had nothing at all to do with Indexhibit but some odd way with how it fundamentally works.

fransvax
UNITED STATES
1 year(s) ago
Permalink Post

the html5 viewing is set up on vimeo, when you go to a vimeo page you have the choice (written in small, on the right side) to switch to flash or html5 player. It will actually also act on any embedded vimeo you come across afterward.

I understand that it is not an indexhibit bug, for sure. But I was wondering if you might see more clearly than I am what was causing the issue as I don't have a deep understanding of indexhibit as you must have.

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

I don't see it. What I see is a huge amount of things going on at the same time.

And, I could never get Vimeo html5 to work for me in general.

I'm happy to try to help see the problem more clearly...but it's late where I am and I'm about to go to sleep. Feel free to send me an email and maybe we can find a moment to brainstorm on this...

fabian2rivero
COLOMBIA
1 year(s) ago
Permalink Post

Hi there!
I want to use the Royal Slider, but I don't have any idea of how to do the installation!
Can you (fransvax or vaska) explain it, please?
thanks!

Vaska A
UNITED STATES
1 year(s) ago
Permalink Post

I don't know anything about it...

 

This thread has been closed, thank you.