Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

upgrading didn't work.

 

Indexhibit version: 2.0
Thread is resolved.

ChrisClaus
UNITED STATES
4 year(s) ago
Permalink Post

Hello,
I tried to upgrade my website by following those steps; Upgrading to Indexhibit 2 from version 0.73 or older but in the end I can't find any of my old stuff for my old version. Do I have to re-do my website from scratch?
I don't know if I did something wrong or if I should re-do the whole thing again.
Here is my link: kiritinbeyer.com

Keep me updated if you have any ideas. Thanks,

arsondpi
GREECE
4 year(s) ago
Permalink Post

Hello!

I don't really know what you've done. If you upgraded you should still have access to your old site (kiritinbeyer.com/…)
Have you kept backups of your files, folders and database as advised before upgrading?

ChrisClaus
UNITED STATES
4 year(s) ago
Permalink Post

Hello,
Yes I kept a backup of everything, the entire website, database & cPanelBackup. Actually a changed hosting and so I needed to upgrade to version 2. I uploaded my old website via FTP and I imported my SQL folder into PHPadmin on my new hosting and from there I followed the instruction for the upgrade.
My old hosting expired. Maybe because I upgraded while changing hosting I missed a step. Thanks for your help.

arsondpi
GREECE
4 year(s) ago
Permalink Post

But before you upgraded did you see if the old site was working?
Meaning that when transfering to a new host you most likely need to update the config.php file with connects Indexhibit with the database.

ChrisClaus
UNITED STATES
4 year(s) ago
Permalink Post

No it wasn't working. My new hosting told me my website version was too old and I needed the upgrade to PHP5. In the meantime my old hosting expired but I backup everything.
Ok so if I didn't update my php before transferring there is nothing I can do, right?

Best Answer!
arsondpi
GREECE
4 year(s) ago
Permalink Post

What I meant is that you ought to have the correct database connection details from your Legacy version site, update them for your new host and then upgrade.

ChrisClaus
UNITED STATES
4 year(s) ago
Permalink Post

Do I update them by just replacing the config.php file? Sorry I'm novice and learning.

Best Answer!
arsondpi
GREECE
4 year(s) ago
Permalink Post

No open the config.php file in a code editor.
Make sure that it is the correct database details: when you imported the old Legacy version somethings must have changed. Check the Database Server Address, Database Name, Database Username, Database Password.
Then try to upgrade... from scratch (meaning that you delete the existing Version 2 files and database, mainly so you don't get confused)

ChrisClaus
UNITED STATES
4 year(s) ago
Permalink Post

Thank you so much for your help. Everything works perfectly now.

Showing 1 - 9 of 9 posts in Forum » Upgrade » upgrading didn't work.
 

This thread has been closed, thank you.