Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

Trying to get my old site updated with the upgrade

 

Indexhibit version: 2.0
Thread is not resolved.

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

I'm looking to change the "syntax for template variables and plugins" do I update the old files (ndxz-studio) or new files (ndxzstudio) with these instructions?

Basically this for the updated database to reference the old version, correct?

arsondpi
GREECE
4 year(s) ago
Permalink Post

you should update new files - but what exactly are you trying to update?
Indexhibit version 2 has many more features and usually people only update their themes...

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

Ok, with the new files updated correctly, my site should show up as it did pre-upgrade? Is that correct?

arsondpi
GREECE
4 year(s) ago
Permalink Post

Yes. Any customizations may need updating on your theme, but most formats are there for Version 2.

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

Again sorry for the buggering on here, but I'm stumped on what actual files need this updating? I'm really trying to follow these instructions and I keep losing my way.

You call for changes in the "template" what file would the template be located?
Am I updated the default file?

My site from before was very basic and didn't get into much customization.

arsondpi
GREECE
4 year(s) ago
Permalink Post

Hello again.
The default folder (in ndxzsite) is your themes folder. In there you'll a series of files which *may* need updating. In the plugin folder (also in ndxzsite) you have your formats and plugins php files which sometimes work with javascript and css files.

Again as I initially asked: what exactly are you trying to update?
You may not need to update something anyway - probably customize only.

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

Ok cool, yea from the instructions, it sounded like I needed to update my theme. But if the upgrade took care of most of it, I should be ok. My theme was very basic and I guess I then need to fix my css?

Again, my site was very basic and with the some mild customizations (font, colors, navs, etc) What file would recommend I correct?

I see my page (derekdudekdesign.com) come up but all my settings are off from where they were pre-upgrade. -thanks again!

arsondpi
GREECE
4 year(s) ago
Permalink Post

Yep - you need to *update* (and not upgrade) your style.css file located in the default folder as I described above.

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

So I just save it in the same place and upload it as such? Do I need the code from the new default style.css?

I updated my old one and reuploaded, still have the have the same settings.

thanks - Derek

arsondpi
GREECE
4 year(s) ago
Permalink Post

Use the style.css provided with in the default folder (theme folder) in your server.
The old one will not work unless you update it.
Work on the new style.css that was already in the default folder.

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

Ok took a crack at updating it, but I still can't seem to get this right. The new css is setup differently and I am not sure what should be copied over from the previous css. I tried to copy my text setting and such and everything just comes up the same. Sorry, this is just not intuitive for me, but I am trying, thanks.

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

Are you editing the wrong style.css file? Also, can you show us what your older site looked like?

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

I thought that too, I'm working from ndxzsite/ default/ style.css, I tried updating it and its getting me nowhere. Where would my old one be? ( just to be sure im using the right one to update)

My side nav had drop down menus and such. Trying to replicate my old look, but I'm dying here trying to figure out whats getting in the way.

Here's a mockup (just built this in tumblr) basically of what it was:
rekdudekdesign.tumblr.com/post/77985387342/…

arsondpi
GREECE
4 year(s) ago
Permalink Post

Ok -
#menu is now #index
#content is now #exhibit
expanding menus has been replaced by Indexpand (check the Plugins section on the left)

My advice is to download Firebug, the Firefox plugin with which you can target webpage elements and find their css id. Also I think that css bookmarklets are also quite handy - search the internet for css target bookmarklet

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

Ok got it with the menus, thats fixed thanks!

My images are coming up with the broken link icon, shouldn't the upgrade refer it to the old location? What do I update and I have to relink?

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

I tried updating the exhibit formats, but from the look of it doesnt seem like I have to. I had a version of "no thumbs, no captions" Still no luck with it locating the images.

One more issue, my derekdudekdesign.com/ndxzstudio/ interface is all centered aligned and out of wack? Not sure how that happened, any way to fix?

Vaska A
UNITED STATES
4 year(s) ago
Permalink Post

Visit each exhibit from the studio and the images will regenerate.

Your studio login is messed up probably because you edited the wrong stylesheet. Simply reupload /ndxzstudio/asset/css/ folder and files.

ddudek257
UNITED STATES
4 year(s) ago
Permalink Post

Ok got the admin back in order and got the exhibits going, thx! 2 more things:

Trying to get my header image above the nav on my homepage to show up, not sure where in the code that is, last time it came from the old derekdudekdesign.com/index.php

Also, what is the proper path for the homepage's - style.css ?
not sure which one is right.

 

This thread has been closed, thank you.