Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

MyFonts Web Fonts working selectively

 

Indexhibit version: 2.0
Thread is resolved.

tkracauer
UNITED STATES
3 year(s) ago
Permalink Post

Greetings!

Just uploaded a webfont kit from myfonts to my root folder, put the link to the files in my index.php page, set the font as my h1 (which is my site's main title in the index section) and it works...but only on the home page. The font does not generate in any page but my home page.

Is there somewhere besides the head of the index.php file that i need to place the web-font style-sheet link?

tkracauer
UNITED STATES
3 year(s) ago
Permalink Post

here's my site if it helps:

lafineartssquad.com

Thanks for any help you could provide!

tkracauer
UNITED STATES
3 year(s) ago
Permalink Post

This is strange: (mainly because i'm a beginner i'm sure...)

Some of urls for my exhibits have a slash (/) at the end of them as is common. When i delete that slash and reload the page, the web font on that page works! Like I said, SOME of my pages have this final slash, and I suppose i'd like to know how to modify the path of the sections in order to get rid of the slash since that seems to make my web font work.

I'd appreciate any help you could provide.

Best,
Tom

Best Answer!
Vaska A
UNITED STATES
3 year(s) ago
Permalink Post

Nice work!

This is very peculiar.

Also, if I try to access your "MyFontsWebfontsKit.css" I get nothing at all - the file doesn't exist.

Indexhibit has always worked with the trailing slash - I have had things working with webfonts just fine. Try sorting out the .css file above and also, why not use "http://" before your Typekit javascript link?

tkracauer
UNITED STATES
3 year(s) ago
Permalink Post

Vaska,

Thanks for the pointers and the compliment. Like you suggested, the issue was that I was using a relative link to my .css file instead of an absolute link. The webfont worked across the whole site (not just the front page) once i fixed that link. I then celebrated over pizza.

Thanks again.

Best,
Tom

Vaska A
UNITED STATES
3 year(s) ago
Permalink Post

Yay!

Showing 1 - 6 of 6 posts in Forum » Customize » MyFonts Web Fonts working selectively
 

This thread has been closed, thank you.