Indexhibit
Index + Exhibit

Login:

Created by
Daniel Eatock
Jeffery Vaska
And You

Indexhibit was updated to version 2.1.4 on April 10, 2017.

Header Error & Image Problems

 

Indexhibit version: Legacy
Thread is not resolved.

Guy
UNITED KINGDOM
11 year(s) ago
Permalink Post

Hi there,

I have upgraded to the new version and am getting the following header error when I got to index.php:

Warning: Invalid argument supplied for foreach() in /var/www/html/studio/module/exhibits/files.php on line 14

Warning: Cannot modify header information - headers already sent by (output started at /var/www/html/studio/module/exhibits/files.php:14) in /var/www/html/studio/lib/template.php on line 65

I also am unable to load images. When I upload them they do not appear when I view the page/project.

Thanks

Guy
UNITED KINGDOM
11 year(s) ago
Permalink Post

The header error has seemed to vanish luckly. I am still having problems uploading images fullsize. When selecting No Thumbs no camptions the image isn't displayed on the page?

Thanks

Vaska A
UNITED STATES
11 year(s) ago
Permalink Post

Can we see a link?

Also, you probably have v0.63. I goofed on the upload and forgot an important file. Download 0.64...the only change is to /studio/lib/media.php - add this to your /studio/lib folder and it will help.

Guy
UNITED KINGDOM
11 year(s) ago
Permalink Post

Hi,

Apologies forgot a link. Here is an example of what I mean:

http://www.guyhulse.co.uk/project/watertm/

Just uploaded the image and selected No thumbs, no captions. Must be missing something obvious?

I thought I downloaded v0.64 however it's saying that it's v0.63 when I log in. Must have not upgraded properly. I seem to have the media.php file in my lib folder.

Thanks

Vaska A
UNITED STATES
11 year(s) ago
Permalink Post

Do you have an index.htm file in your root? You can not access your site from the root. Also, I can not find the /files or /files/gimgs folder on your site - they aren't there as far as I can see.

OR, maybe you have some strange server setting disallowing access to these folders? Perhaps an htaccess file that is restricting all access to something. From the behavior or the error messages...there are none...and we're defaulted to your index.htm file...I'd say it's an htaccess or server setting issue.

With your FTP app...can you visibly see these folders...and the files?

Guy
UNITED KINGDOM
11 year(s) ago
Permalink Post

Yeah I do have an index.htm. Just a temporary holding page. Will that effect the uploading of images?

Vaska A
UNITED STATES
11 year(s) ago
Permalink Post

No...but it's in the way. Can you see the images on the server via your FTP app?

Guy
UNITED KINGDOM
11 year(s) ago
Permalink Post

I have removed the holding page for now, until I sort this out so it's easier. I can see them via my FTP app, files > gimgs. However I can't seem to access them on the web. They upload when I select 'grow'. Still don't seem to be working ok?

http://www.guyhulse.co.uk/project/voyage-identity/

Might be a problem with my server settings or something.

Vaska A
UNITED STATES
11 year(s) ago
Permalink Post

Try this...

Go into your /studio/defaults.php file and change "define("MODREWRITE", TRUE);" to FALSE...and then delete the htaccess file in your root.

It's either something odd that htaccess is doing...or a different server issue.

Guy
UNITED KINGDOM
11 year(s) ago
Permalink Post

Cheers Vaska, tried that but seems to be exactly the same. Looks like it's something to do with my server settings then.

Showing 1 - 10 of 10 posts in Forum » Customize » Header Error & Image Problems
 

This thread has been closed, thank you.